re = /(?s)\#+\sv2.*?(?=\s*(?:\#+|$))/
str = '#### v2
START MATCH
Text explaning things and stuff.
This has to be matched.
END MATCH
#### v1
Do not match this part (or anything
below "END MATCH" part).
#### v0
Do not match this either.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end