import re
regex = re.compile(r"(?s)<!-- @\[(?<name>\w+)\((?<type>\w+)\)\] -->\s+# (?<h1>[\w ]+?)\s+<!-- @\[(?<name2>\w+)\] -->\s+## (?<h2>[\w ]+?)\s+```(?<codeType>\w+)\s+(?<code>.*?)```\s+<!-- @\[\/(?<parent>\w+)\] -->", flags=re.MULTILINE)
test_str = ("<!-- @[Hero(super)] -->\n\n"
"# Creating new contexts\n\n"
"<!-- @[UsageExample] -->\n\n"
"## Usage example\n\n"
"```javascript\n"
" Import { ICON_NAME } from 'Icons'\n"
"```\n\n"
"<!-- @[/Hero] -->\n\n"
"<!-- @[ArticleSection] -->")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")