const regex = new RegExp('(?i)\\b(Devices|Community String)\\b\\s*-\\s*([\\w,\\/]+)', 'gm')
const str = `1. What is being changed?
Add in Solarwinds monitoring the router and switch of the new Store:
Devices - MCHLS5178,sw517801,sr517800,sr517801,sr517802,MCHLS5184,sw518401,sr518400,sr518401,sr518402
Community String - N/A
2. Where it is being changed?
Solarwinds monitoring (10.3.4.7)
3. Why it is being changed?
To monitor the router and switch of the store 5178,5184
4. What is the Business Impact of the Change?
No business impact during implementation.
5. Who will be doing the change?
Network team
6. When is the change happening?
2020-01-26 01:00:00
7. Who will be testing the change after implementation?
Network team`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}