const regex = /([^\/]+)_\d+x\d+\.png/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^\\\/]+)_\\d+x\\d+\\.png', 'gm')
const str = `images/tJpwYL9baWgH56USKZwqTz7QM9g1_48x48.png
https://.../.../images/tJpwYL9baWgH56USKZwqTz7QM9g1_150x150.png`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}