re = /([^\/]+)_\d+x\d+\.png/m
str = 'images/tJpwYL9baWgH56USKZwqTz7QM9g1_48x48.png
https://.../.../images/tJpwYL9baWgH56USKZwqTz7QM9g1_150x150.png'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end