const regex = /(?<=First Name:\s*\*).*?(?=\*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=First Name:\\s*\\*).*?(?=\\*)', 'gm')
const str = `Email: *abc@gmail.com \`<abc@gmail.com>\`*
First Name: *John Doe*
Phone Number: *123456789*
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}