re = /(?<=First Name:\s*\*).*?(?=\*)/m
str = 'Email: *abc@gmail.com `<abc@gmail.com>`*
First Name: *John Doe*
Phone Number: *123456789*
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end