import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "glf-button|//(.*?\\.)?(deliveroo|glovoapp|justeat|ubereats|foodys|ideariadelivery).*?\\.";
final String string = "https://www.ideariadelivery.it/ordering/restaurant/menu?restaurant_uid=403c682d-5f66-46c0-8ce0-2f1638185f7d";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}