$re = '~glf-button|//(.*?\.)?(deliveroo|glovoapp|justeat|ubereats|foodys|ideariadelivery).*?\.~m';
$str = 'https://www.ideariadelivery.it/ordering/restaurant/menu?restaurant_uid=403c682d-5f66-46c0-8ce0-2f1638185f7d';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);