import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ", услуги,[^)]+;";
final String string = "1. Иванов Иван Иванович - оказываются услуги проживания (2-х местный двухкомнатный Люкс, Основное место), услуги питания (Заказное меню), медицинские услуги (Лечение), услуги, связанные с организацией туристического путешествия; 2. Петров Пётр Петрович - оказываются услуги проживания (2-х местный двухкомнатный Люкс, Дополнительное место), услуги питания (Заказное меню), услуги, связанные с организацией туристического путешествия (без оказания медицинских услуг); 3. Семенов Семён Семёнович - оказываются медицинские услуги (Лечение), услуги, связанные с организацией туристического путешествия (без оказания услуг проживания, услуг питания);";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}