$re = '/(\'[^\']*\'(*SKIP)(*FAIL))|,/';
$str = '16588, 16503, 1, 1, N\'1, 2, 3 RUE MENESTRELS\', 12, 153';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);