// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"('[^']*'(*SKIP)(*FAIL))|,").unwrap();
let string = "16588, 16503, 1, 1, N'1, 2, 3 RUE MENESTRELS', 12, 153";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}