package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([\u30a0-\u30ff]|[\uff00-\uff20])+$`)
var str = `$アイウエオ`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}