$re = '/^([\u30a0-\u30ff]|[\uff00-\uff20])+$/';
$str = '$アイウエオ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);