package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<field1>\S+)(\s+(?<field2>\S+))?\s+(?<field3>\S+)$`)
var str = `value1 another_value yet_another_value
first_value this_time_just_second_one`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}