$re = '/^(?<field1>\S+)(\s+(?<field2>\S+))?\s+(?<field3>\S+)$/m';
$str = 'value1 another_value yet_another_value
first_value this_time_just_second_one';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);