$re = '/\)"?,"?\(/m';
$str = '{"(RIR010,\\"not willing to take\\")","(RIR003,\\"patient wishes to try alternative\\")"}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);