re = /\)"?,"?\(/m
str = '{"(RIR010,\\"not willing to take\\")","(RIR003,\\"patient wishes to try alternative\\")"}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end