import re
regex = re.compile(r"^((?!xyz).)*1.*$", flags=re.MULTILINE)
test_str = ("Anytext1 Anytext2 xyz Anytext1 xyz AnyText1 xyz\n"
"Anytext0 Anytext2 xyz AnyText1 xyz Anytext1 xyz AnyText1 xyz AnyText1 xyz\n"
"some text 1 xyz 1\n"
"some text with xyz 1 xyz 1 1\n"
"1\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")