use strict;
my $str = 'AB2001482 AB0783714, AB0783714-Q ABBILD NRRHLAT 10 XäZ 207,25';
my $regex = qr/^(?<startwort>AB[\w\d-]*\d[\w\d-]*)(?>\s*,\s*|\s+)(?<startplus>(?>AB[\w\d-]*\d[\w\d-]*(?>\s*,\s*|\s+))*)(?<vorwort>.*)\s+(?<zahl>\d+)\s+(?<wort>[a-zA-Z0-9_üöä]+)\s+(?<betrag>[\d.,]+)\s*$/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}