import re
regex = re.compile(r"(?=(?:.*\d){3})(?=(?:.*[a-z]){3})^[a-z\d]*$", flags=re.MULTILINE)
test_str = ("abc123\n"
"a2v1c3\n"
"123agc")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")