# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([^\s=]+=)[\p{Zs}\t]*$"
test_str = ("Caption=http://support.microsoft.com/?kbid=3150513\n\n"
"CSName=DC04\n\n"
"Description=Update\n\n"
"FixComments= \n\n"
"HotFixID=KB3150513\n\n"
"InstallDate=\n\n"
"InstalledBy=NT AUTHORITY\\SYSTEM\n\n"
"InstalledOn=11/29/2022\n\n"
"Name=\n\n"
"ServicePackInEffect=\n\n"
"Status=")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.