import Foundation
let pattern = #"^([^\s=]+=)[\p{Zs}\t]*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Caption=http://support.microsoft.com/?kbid=3150513
CSName=DC04
Description=Update
FixComments=
HotFixID=KB3150513
InstallDate=
InstalledBy=NT AUTHORITY\SYSTEM
InstalledOn=11/29/2022
Name=
ServicePackInEffect=
Status=
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)