using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w+@\w{1,63}\.[a-z]{3}";
string input = @"abc
testing@longName63IstheMaxforthisthisismorethanthatnotsurewhenisittoomuch.com
tdedonno@juno.com
tdedonno@saddleback.edu
problem_123@nonStandard_.edu
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}