import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\w+@\\w{1,63}\\.[a-z]{3}";
final String string = "abc\n\n"
+ "testing@longName63IstheMaxforthisthisismorethanthatnotsurewhenisittoomuch.com\n\n"
+ "tdedonno@juno.com\n\n"
+ "tdedonno@saddleback.edu\n\n"
+ "problem_123@nonStandard_.edu\n\n\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}