package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(a.*){2}b.*b|(b.*){2}a.*a|(a.*b|b.*a){2}`)
var str = `babba
baaaa
bbbaca
asdifhiusa
ajsdbb
bbaasdfwer
aaccbb
acabdb`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}