$re = '/(a.*){2}b.*b|(b.*){2}a.*a|(a.*b|b.*a){2}/m';
$str = 'babba
baaaa
bbbaca
asdifhiusa
ajsdbb
bbaasdfwer
aaccbb
acabdb';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);