using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(group|another_group)|([^\s]+)";
string input = @"group g1 l1 l2 l3 g2 g3.l1
another_group g1 l1 l2 l3 g2 g3.l1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}