package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(group|another_group)|([^\s]+)`)
var str = `group g1 l1 l2 l3 g2 g3.l1
another_group g1 l1 l2 l3 g2 g3.l1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}