package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`_([^_]*_[^_]*)$`)
var str = `test1_test2_test3_test4_test5`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}