$re = '/_([^_]*_[^_]*)$/';
$str = 'test1_test2_test3_test4_test5';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);