using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".log(.[0-9]+)?$";
string input = @"auth.log.1
auth.log.99";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}