$re = '/.log(.[0-9]+)?$/m';
$str = 'auth.log.1
auth.log.99';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);