use strict;
my $str = '<?xml version=\'1.0\' encoding=\'UTF-8\'?>
<kml xmlns=\'http://earth.google.com/kml/2.0\'>
<Folder>
<Style id=\'icon243\'>
<IconStyle>
<Icon>
<href>https://poi.gpsforalle.dk/img_icon_show.php?cid=243</href>
</Icon>
</IconStyle>
</Style>
<Style id=\'icon_ok\'>
<IconStyle>
<Icon>
<href>http://maps.google.com/mapfiles/kml/pushpin/grn-pushpin.png</href>
</Icon>
</IconStyle>
</Style>
<Style id=\'icon_bad\'>
<IconStyle>
<Icon>
<href>http://maps.google.com/mapfiles/kml/pushpin/red-pushpin.png</href>
</Icon>
</IconStyle>
</Style>
<Folder>
<name>Attraktioner</name>
<Folder>
<name>Forlystelser</name>
<Placemark>
<styleUrl>#icon243</styleUrl>
<name>Baboon City Herning</name>
<address>Åkirkebyvej 10
7400 Herning</address>
<phoneNumber>+45 97 22 13 14</phoneNumber>
<Point>
<coordinates>8.97809,56.15279,0</coordinates>
</Point>
</Placemark>
<Placemark>
<styleUrl>#icon243</styleUrl>
<name>Bakken Klampenborg</name>
<address>Dyrehavevej 62
2930 Klampenborg</address>
<phoneNumber>+45 39 63 35 44</phoneNumber>
<Point>
<coordinates>12.57905,55.77484,0</coordinates>
</Point>
</Placemark>
<Placemark>
<styleUrl>#icon243</styleUrl>
<name>Beach Bowl A/S Ringkøbing</name>
<address>Lodbergsvej 36
6950 Ringkøbing</address>
<phoneNumber>+45 97 33 89 00</phoneNumber>
<Point>
<coordinates>8.11473,56.12247,0</coordinates>
</Point>
</Placemark>
<Placemark>
<styleUrl>#icon243</styleUrl>
<name>Bonbon-Land Holmegaard</name>
<address>Gartnervej 2
4684 Holmegaard</address>
<phoneNumber>+45 55 53 07 00</phoneNumber>
<Point>
<coordinates>11.86094,55.26057,0</coordinates>
</Point>
</Placemark>
<Placemark>
<styleUrl>#icon243</styleUrl>
<name>Bornholms Middelaldercenter Gudhjem</name>
<address>Stangevej 1
3760 Gudhjem</address>
<phoneNumber>+45 56 49 83 19</phoneNumber>
<Point>
<coordinates>14.95664,55.17535,0</coordinates>
</Point>
</Placemark>
<Placemark>
<styleUrl>#icon243</styleUrl>
<name>Brændesgårdshaven Svaneke</name>
<address>Højevejen 4
3740 Svaneke</address>
<phoneNumber>+45 56 49 60 76</phoneNumber>
<Point>
<coordinates>15.10366,55.12917,0</coordinates>
</Point>
</Placemark>
<Placemark>
<styleUrl>#icon243</styleUrl>
<name>Børnenes Eventyrfabrik Kokkedal</name>
<address>Industripark 11
2980 Kokkedal</address>
<phoneNumber>+45 48 14 00 06</phoneNumber>
<Point>
<coordinates>12.48366,55.90240,0</coordinates>
</Point>
</Placemark>
<Placemark>
<styleUrl>#icon243</styleUrl>
<name>Cecilie\'s Herlev</name>
<address>Hørkær 1-3
2730 Herlev</address>
<phoneNumber>+45 55 55 50 50</phoneNumber>
<Point>
<coordinates>12.43004,55.72063,0</coordinates>
</Point>
</Placemark>
<Placemark>
<styleUrl>#icon243</styleUrl>
<name>Christiansminde Minigolf Svendborg</name>
<address>Christiansmindevej 20
5700 Svendborg</address>
<phoneNumber>+45 53 13 00 09</phoneNumber>
<Point>
<coordinates>10.63836,55.05997,0</coordinates>
</Point>
</Placemark>
<Placemark>
<styleUrl>#icon243</styleUrl>
<name>Danfoss Universe Nordborg</name>
<address>Mads Patent Vej 1
6430 Nordborg</address>
<phoneNumber>+45 74 88 95 00</phoneNumber>
<Point>
<coordinates>9.80957,55.04147,0</coordinates>
</Point>
</Placemark>
<Placemark>
<styleUrl>#icon243</styleUrl>
<name>Dinos Legeland Ishøj</name>
<address>Industribuen 7C
2635 Ishøj</address>
<phoneNumber>+45 70 20 70 76</phoneNumber>
<Point>
<coordinates>12.33468,55.61783,0</coordinates>
</Point>
</Placemark>
<Placemark>
<styleUrl>#icon243</styleUrl>
<name>Dinos Legeland København S</name>
<address>Asger Jorns Allé 4
2300 København S</address>
<phoneNumber>+45 70 20 70 76</phoneNumber>
<Point>
<coordinates>12.57445,55.61966,0</coordinates>
</Point>
</Placemark>
<Placemark>
<styleUrl>#icon243</styleUrl>
<name>Dinos Legeland Fredericia</name>
<address>Nørrebrogade 121
7000 Fredericia</address>
<phoneNumber>+45 75 92 20 10</phoneNumber>
<Point>
<coordinates>9.74471,55.57831,0</coordinates>
</Point>
</Placemark>
<Placemark>
<styleUrl>#icon243</styleUrl>
<name>Djurs Sommerland Nimtofte</name>
<address>Randersvej 17
8581 Nimtofte</address>
<phoneNumber>+45 86 39 84 00</phoneNumber>
<Point>
<coordinates>10.55086,56.42646,0</coordinates>
</Point>
</Placemark>
<Placemark>
<styleUrl>#icon243</styleUrl>
<name>Eventyrs fabrikken Mega Center Ballerup Ballerup</name>
<address>Telegrafvej 2
2750 Ballerup</address>
<phoneNumber>+45 44 68 22 96</phoneNumber>
<Point>
<coordinates>12.34713,55.73278,0</coordinates>
</Point>
</Placemark>
<Placemark>
<styleUrl>#icon243</styleUrl>
<name>Experimentarium Hellerup Hellerup</name>
<address>Tuborg Havnevej 7
2900 Hellerup</address>
<phoneNumber>+45 39 27 33 33</phoneNumber>
<Point>
<coordinates>12.57962,55.72661,0</coordinates>
</Point>
</Placemark>
<Placemark>
<styleUrl>#icon243</styleUrl>
<name>Fiske og Familiepark West Ringkøbing</name>
<address>Hovervej 56-58
6950 Ringkøbing</address>
<phoneNumber>+45 97 33 54 11</phoneNumber>
<Point>
<coordinates>8.29847,56.14273,0</coordinates>
</Point>
</Placemark>
<Placemark>
<styleUrl>#icon243</styleUrl>
<name>Fårup Sommerland Saltum</name>
<address>Pirupvejen 147
9492 Saltum</address>
<phoneNumber>+45 98 88 16 00</phoneNumber>
<Point>
<coordinates>9.64932,57.27051,0</coordinates>
</Point>
</Placemark>
<Placemark>
<styleUrl>#icon243</styleUrl>
<name>Gerlev Legepark Slagelse</name>
<address>Skælskør Landevej 28
4200 Slagelse</address>
<phoneNumber>+45 58 58 40 65</phoneNumber>
<Point>
<coordinates>11.32872,55.35485,0</coordinates>
</Point>
</Placemark>
<Placemark>
<styleUrl>#icon243</styleUrl>
<name>Hasle Camping Minigolf Hasle</name>
<address>Fælledvej 30
3790 Hasle</address>
<phoneNumber>+45 56 94 53 00</phoneNumber>
<Point>
<coordinates>14.70721,55.17903,0</coordinates>
</Point>
</Placemark>
<Placemark>
<styleUrl>#icon243</styleUrl>
<name>Jesperhus Nykøbing M</name>
<address>Legindvej 30
7900 Nykøbing M</address>
<phoneNumber>+45 96 70 14 00</phoneNumber>
<Point>
<coordinates>8.81502,56.76437,0</coordinates>
</Point>
</Placemark>
<Placemark>
<styleUrl>#icon243</styleUrl>
<name>Labyrinthia Them</name>
<address>Gl. Ryvej 2
8653 Them</address>
<phoneNumber>+45 86 84 99 44</phoneNumber>
<Point>
<coordinates>9.57570,56.10658,0</coordinates>
</Point>
</Placemark>
<Placemark>
<styleUrl>#icon243</styleUrl>
<name>LegeJunglen Slangerup</name>
<address>Københavnsvej 19
3550 Slangerup</address>
<phoneNumber>+45 70 22 24 68</phoneNumber>
<Point>
<coordinates>12.18030,55.84386,0</coordinates>
</Point>
</Placemark>
<Placemark>
<styleUrl>#icon243</styleUrl>
<name>Legeparken Kolding</name>
<address>Grønningen 2
6000 Kolding</address>
<phoneNumber>+45 23 72 67 36</phoneNumber>
<Point>
<coordinates>9.48116,55.49495,0</coordinates>
</Point>
</Placemark>
<Placemark>
<styleUrl>#icon243</styleUrl>
<name>Legoland Billund</name>
<address>Nordmarksvej
7190 Billund</address>
<phoneNumber>+45 75 33 13 33</phoneNumber>
<Point>
<coordinates>9.13085,55.73514,0</coordinates>
</Point>
</Placemark>
<Placemark>
<styleUrl>#icon243</styleUrl>
<name>Leos Legeland Herlev Herlev</name>
<address>Herlev Hovedgade 31
2730 Herlev</address>
<phoneNumber>+45 44 65 00 60</phoneNumber>
<Point>
<coordinates>12.44959,55.71780,0</coordinates>
</Point>
</Placemark>
<Placemark>
<styleUrl>#icon243</styleUrl>
<name>Leos Legeland Ishøj Ishøj</name>
<address>Industribuen 5
2635 Ishøj</address>
<phoneNumber>+45 38 42 27 00</phoneNumber>
<Point>
<coordinates>12.33460,55.61883,0</coordinates>
</Point>
</Placemark>
<Placemark>
<styleUrl>#icon243</styleUrl>
<name>Leos Legeland Odense Odense C</name>
<address>Petersmindevej 1E
5000 Odense C</address>
<phoneNumber>+45 97 12 12 94</phoneNumber>
<Point>
<coordinates>10.42132,55.40389,0</coordinates>
</Point>
</Placemark>
<Placemark>
<styleUrl>#icon243</styleUrl>
<name>Leos Legeland Aalborg Aalborg</name>
<address>Poul Larsens Vej 12
9000 Aalborg</address>
<phoneNumber>+45 98 12 12 94</phoneNumber>
<Point>
<coordinates>9.93355,57.03388,0</coordinates>
</Point>
</Placemark>
<Placemark>
<styleUrl>#icon243</styleUrl>
<name>Leos Legeland Aarhus Aarhus N</name>
<address>Grahambells vej 12
8200 Aarhus N</address>
<phoneNumber>+45 86 21 00 20</phoneNumber>
<Point>
<coordinates>10.18486,56.20308,0</coordinates>
</Point>
</Placemark>
<Placemark>
<styleUrl>#icon243</styleUrl>
<name>Madsby Legepark Fredericia</name>
<address>Lumbyesvej 45
7000 Fredericia</address>
<phoneNumber>+45 72 10 68 62</phoneNumber>
<Point>
<coordinates>9.73711,55.57021,0</coordinates>
</Point>
</Placemark>
<Placemark>
<styleUrl>#icon243</styleUrl>
<name>Minigolfbanen Saxild Odder</name>
<address>Skovduevej 188
8300 Odder</address>
<phoneNumber>+45 86 55 85 79</phoneNumber>
<Point>
<coordinates>10.24980,55.97460,0</coordinates>
</Point>
</Placemark>
<Placemark>
<styleUrl>#icon243</styleUrl>
<name>NaturBornholm Aaekirkeby</name>
<address>Grønningen 30
3720 Aaekirkeby</address>
<phoneNumber>+45 56 94 04 00</phoneNumber>
<Point>
<coordinates>14.91738,55.06420,0</coordinates>
</Point>
</Placemark>
<Placemark>
<styleUrl>#icon243</styleUrl>
<name>Nicolai for børn Kolding</name>
<address>Skolegade 2 C
6000 Kolding</address>
<phoneNumber>+45 79 79 75 75</phoneNumber>
<Point>
<coordinates>9.47069,55.49103,0</coordinates>
</Point>
</Placemark>
<Placemark>
<styleUrl>#icon243</styleUrl>
<name>Power Racing Gokart Akademi Herlev</name>
<address>Lyskær 7
2730 Herlev</address>
<phoneNumber>+45 20 33 77 22</phoneNumber>
<Point>
<coordinates>12.43445,55.71431,0</coordinates>
</Point>
</Placemark>
<Placemark>
<styleUrl>#icon243</styleUrl>
<name>Rømø Familie- og Hesteland Rømø</name>
<address>Havnebyvej 201
6792 Rømø</address>
<phoneNumber>+45 74 75 51 22</phoneNumber>
<Point>
<coordinates>8.54310,55.09942,0</coordinates>
</Point>
</Placemark>
<Placemark>
<styleUrl>#icon243</styleUrl>
<name>Samsø Labyrinten Samsø</name>
<address>Issehoved 1
8305 Samsø</address>
<phoneNumber>+45 24 27 37 17</phoneNumber>
<Point>
<coordinates>10.55426,55.97243,0</coordinates>
</Point>
</Placemark>
<Placemark>
<styleUrl>#icon243</styleUrl>
<name>Sommerland Sjælland Nørre Asmindrup</name>
<address>Gl. Nykøbingvej 169
4572 Nørre Asmindrup</address>
<phoneNumber>+45 59 31 21 00</phoneNumber>
<Point>
<coordinates>11.61068,55.89626,0</coordinates>
</Point>
</Placemark>
<Placemark>
<styleUrl>#icon243</styleUrl>
<name>Stevns Camping Minigolf Strøby</name>
<address>Strandvejen 29
4671 Strøby</address>
<phoneNumber>+45 60 14 41 54</phoneNumber>
<Point>
<coordinates>12.29022,55.39788,0</coordinates>
</Point>
</Placemark>
<Placemark>
<styleUrl>#icon243</styleUrl>
<name>Strandskovens Minigolf Ballen</name>
<address>Strandskoven 7
8305 Ballen</address>
<Point>
<coordinates>10.63795,55.83362,0</coordinates>
</Point>
</Placemark>
<Placemark>
<styleUrl>#icon243</styleUrl>
<name>Texas Ranch Klippinge</name>
<address>Kirkeskovvej 30
4672 Klippinge</address>
<phoneNumber>+45 46 40 37 32</phoneNumber>
<Point>
<coordinates>12.29922,55.33253,0</coordinates>
</Point>
</Placemark>
<Placemark>
<styleUrl>#icon243</styleUrl>
<name>Tivoli København V</name>
<address>Vesterbrogade 3
1611 København V</address>
<phoneNumber>+45 33 15 10 01</phoneNumber>
<Point>
<coordinates>12.56816,55.67368,0</coordinates>
</Point>
</Placemark>
<Placemark>
<styleUrl>#icon243</styleUrl>
<name>Tivoli Friheden Aarhus C</name>
<address>Skovbrynet 5
8000 Aarhus C</address>
<phoneNumber>+45 86 14 73 00</phoneNumber>
<Point>
<coordinates>10.19589,56.13718,0</coordinates>
</Point>
</Placemark>
<Placemark>
<styleUrl>#icon243</styleUrl>
<name>Vallø Stifts Camping Minigolf Køge</name>
<address>Strandvejen 102
4600 Køge</address>
<Point>
<coordinates>12.19201,55.44575,0</coordinates>
</Point>
</Placemark>
<Placemark>
<styleUrl>#icon243</styleUrl>
<name>Vollerup Minigolf & Legeplads Sønderborg</name>
<address>Mommarkvej 22
6400 Sønderborg</address>
<phoneNumber>+45 74 42 39 90</phoneNumber>
<Point>
<coordinates>9.85457,54.92542,0</coordinates>
</Point>
</Placemark>
</Folder>
</Folder>
</Folder>
</kml>
';
my $regex = qr/ <name>([^<]+).*\n(?:.*\n){0,8}.*\n.*\n\s+<coordinates>(\d+\.\d+),(\d+\.\d+)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}