package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)^where's the wiki`)
var str = `where's the wiki `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}