using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*scan=(\d+)$";
string input = @"mzspec=20161213_NGHF_DBJ_SA_Exp3A_HeLa_1ug_7min_15000_02.raw: controllerType=0 controllerNumber=1 scan=2";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}