re = /.*scan=(\d+)$/
str = 'mzspec=20161213_NGHF_DBJ_SA_Exp3A_HeLa_1ug_7min_15000_02.raw: controllerType=0 controllerNumber=1 scan=2'
# Print the match result
str.match(re) do |match|
puts match.to_s
end