import re
regex = re.compile(r"\.(css|scss)$", flags=re.MULTILINE)
test_str = ("# NEED\n"
"index.css\n"
"index.scss\n\n"
"# NOT NEED\n"
"index.module.css\n"
"index.module.scss\n\n"
"# NOT NEED TOO\n"
"index.js\n"
"index.ts")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")