import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "SensorId=(?<sensorId>[^ ]+).*Type=(?<type>[^ ]+).*Unit=(?<unit>[^ ]+).*Granularity=(?<granularity>[^ ]+)";
final String string = "SensorId=11960_P2 Description=DMC 8 - #10 - Pressao VRP 1 (R Sul) Type=P Unit=Bar Granularity=15 SensorLocationRowId=90 Rmse= EpanetId= ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}