const regex = /SensorId=(?<sensorId>[^ ]+).*Type=(?<type>[^ ]+).*Unit=(?<unit>[^ ]+).*Granularity=(?<granularity>[^ ]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('SensorId=(?<sensorId>[^ ]+).*Type=(?<type>[^ ]+).*Unit=(?<unit>[^ ]+).*Granularity=(?<granularity>[^ ]+)', 'gm')
const str = `SensorId=11960_P2 Description=DMC 8 - #10 - Pressao VRP 1 (R Sul) Type=P Unit=Bar Granularity=15 SensorLocationRowId=90 Rmse= EpanetId= `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}