import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((([A-Za-z]{3,9}:(?:\\/\\/)?)(?:[-;:&=\\+\\$,\\w]+@)?[A-Za-z0-9.-]+|(?:www.|[-;:&=\\+\\$,\\w]+@)[A-Za-z0-9.-]+)(:[0-9]{0,5})?(#[\\w]*)?((?:\\/[\\+~%\\/.\\w\\-_]*)?\\??(?:[-\\+=&;%@.\\w_]*)#?(?:[.\\!\\/\\\\w]*))?)";
final String string = "https://habibs.myportfolio.com\n"
+ "www.whatever.com\n"
+ "https://github.com/i-hate-regex\n"
+ "https://www.facebook.com/\n"
+ "https://www.google.com/\n"
+ "https://xkcd.com/2293/\n"
+ "http://www.example.com/\n"
+ "www.google.com\n"
+ "http://www.google.com\n"
+ "mailto:somebody@google.com\n"
+ "somebody@google.com\n"
+ "www.url-with-querystring.com/?url=has-querystring\n\n\n"
+ "https://this-shouldn't.match\n"
+ "and-this.df";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}