re = /((([A-Za-z]{3,9}:(?:\/\/)?)(?:[-;:&=\+\$,\w]+@)?[A-Za-z0-9.-]+|(?:www.|[-;:&=\+\$,\w]+@)[A-Za-z0-9.-]+)(:[0-9]{0,5})?(#[\w]*)?((?:\/[\+~%\/.\w\-_]*)?\??(?:[-\+=&;%@.\w_]*)#?(?:[.\!\/\\w]*))?)/i
str = 'https://habibs.myportfolio.com
www.whatever.com
https://github.com/i-hate-regex
https://www.facebook.com/
https://www.google.com/
https://xkcd.com/2293/
http://www.example.com/
www.google.com
http://www.google.com
mailto:somebody@google.com
somebody@google.com
www.url-with-querystring.com/?url=has-querystring
https://this-shouldn\'t.match
and-this.df'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end