#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "%?\s*\\footnote(\{(?:[^{}]*|(?-1))*})"
Local $sString = "Some text with a short footnote.\footnote{Some \textbf{explanation}.}" & @CRLF & _
"" & @CRLF & _
"Some text with a longer footnote.%" & @CRLF & _
" \footnote{Lorem ipsum dolor" & @CRLF & _
" sit amet, etc. etc. etc. \emph{along \emph{multiple} lines}" & @CRLF & _
" but all lines increased indent from the start.}" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)