$re = '~%?\s*\\\\footnote(\{(?:[^{}]*|(?-1))*})~';
$str = 'Some text with a short footnote.\\footnote{Some \\textbf{explanation}.}
Some text with a longer footnote.%
\\footnote{Lorem ipsum dolor
sit amet, etc. etc. etc. \\emph{along \\emph{multiple} lines}
but all lines increased indent from the start.}
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;