package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b[^.]+\([^()]+\b(\d{2}|\d{4})\s*\)[^.]*\.`)
var str = `Abc def ghi (foo 2015).
Trondheim is a small city with a university and 140000 inhabitants. Its central bus systems has 42 bus lines, serving 590 stations, with 1900 (departures per) day in average. T h a t gives approximately 60000 scheduled bus station passings per day, which is somehow represented in the route data base. The starting point is to automate the function (Garry Weber, 2005) of a route information agent.
Abc def ghi (foo 2015).
Abc def ghi (foo 201).`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}