const regex = /^@(?:id|class)=.*?( on[a-z]*=.*)?["']$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^@(?:id|class)=.*?( on[a-z]*=.*)?["\']$', 'gm')
const str = `@id="query oninput= onmouseover="
@id="myLabel" for="query"
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}