$re = '/^@(?:id|class)=.*?( on[a-z]*=.*)?["\']$/m';
$str = '@id="query oninput= onmouseover="
@id="myLabel" for="query"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);