using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"jdbc:sqlserver:\/\/(\w+).(.+):(\w+)";
string input = @" jdbc:sqlserver://testserver.apple.com\A4534:54623";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}