$re = '/jdbc:sqlserver:\/\/(\w+).(.+):(\w+)/m';
$str = ' jdbc:sqlserver://testserver.apple.com\\A4534:54623';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);