#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mu)((?:<[^>]*>[^<]*?)*?(?:(?!<mark>)<[^>]*(?=>))?)(\W|^)(eiusmod|sort|incididunt|dolor|única|feté)(?=\W|$)"
Local $sString = "única<div data-sort="1">" & @CRLF & _
"" & @CRLF & _
"<p>dolor</p>" & @CRLF & _
"<p>única</p>" & @CRLF & _
"" & @CRLF & _
"<h1 data-position="1" eiusmod="foo" >Lorem ipsum dolor sit amet</h1>" & @CRLF & _
"<div data="eiusmod"></div>" & @CRLF & _
"<strong>search here : consectetur adipiscing elit, </strong>" & @CRLF & _
"<div>" & @CRLF & _
"sed do <u>eiusmod</u> tempor <mark>incididunt</mark> ut dolor et dolor dolor magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat." & @CRLF & _
"</div>" & @CRLF & _
"Duis aute irure <i>dolor</i> dolor in dolor dolor reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum." & @CRLF & _
"</div>" & @CRLF & _
"" & @CRLF & _
"<div>" & @CRLF & _
"sed do <u>eiusmod</u> tempor <mark>incididunt</mark> ut única et única púnica magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat." & @CRLF & _
"</div>" & @CRLF & _
"<div>fetén</div>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "\1\2<mark>\3</mark>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)